4.1 firewire installation work-around

Common questions with answers. Please look in here if you find the answer to your problem before posting.

4.1 firewire installation work-around

Postby StarKnight83 » 22 Apr 2006, 13:57

First of all, Credit for this goes to Martin "Jerry" Jerabek of the YDL mailing list. Here is his post of a work-around on the firewire install for 4.1 emails and web addresses removed cause of stupid spam spiders


Message: 1
Date: Sun, 16 Apr 2006 18:12:08 +0200
From: Martin Jerabek
Subject: Firewire installation problems & solution
To: yellowdog-newbie
Message-ID: <44426CD8.7090807@xstnz.tk>
Content-Type: text/plain; charset=ISO-8859-15; format=flowed


Like other people here I had problems installing YDL 4.1 on an external
firewire drive. My Mac is an iBook G3 900MHz. Despite booting with
"install firewire" the installer simply did not list the firewire drive,
so I could not install anything on it. The drive itself worked well
under Mac OS X, so I knew it was only a software problem. The dmesg
output did not show any traces of the firewire controller or drives, so
it was not surprising that the installer did not offer it.

After some experiments I found the following solution which allowed me
to install YDL 4.1 on a firewire drive and boot from it. It is a bit
involved but it has only be done once. Maybe someone can find an easier way:

- Boot from the installation CD with "install firewire".
- Wait until the graphical installer is started and switch to a console
with a shell by pressing Alt+Ctrl+F2 (on iBooks you also have to press
Fn simultaneously to get the function key).
- Extract the kernel firewire modules by entering the following commands
(everything after gunzip must be on the same line):
cd /modules
gunzip -c modules.cgz | cpio -id

If this does not create a 2.6.15-rc5.ydl.1/ppc subdirectory you can list
the contents of the cpio archive with
gunzip -c modules.cgz | cpio -t
to see if the directory names are different in your version.

- Load the firewire kernel modules:
cd 2.6.15-rc5.ydl.1/ppc
modprobe ieee1394.ko
modprobe ohci1394.ko
modprobe sbp2.ko

- If you enter "dmesg" now the firewire drive(s) should be listed at the
end of its output. I have a firewire DVD drive and a harddisk; the DVD
drive is sr0, and the harddisk is sda.

- Create device entries for the firewire harddisk:
cd /dev
makedevs sda b 8 0 0 31 s

- For unknown reasons the installer still did not recognize the firewire
harddisk but entering


fixed it.

- Switch back to the graphical installer with Alt+Ctrl+F7 (again with Fn
if necessary) and start the installation. The disk partitioner should
now list the firewire drive (in my case as "sda") and let you install
YDL on it.

In my case the installation went smoothly but I could not boot from the
firewire drive by holding Alt during the restart and choosing the
firewire drive as the boot device. I could select the firewire drive and
start to boot from it but when I entered "l" to boot Linux my Mac simply
returned to the graphical boot device chooser (with slightly wrong
colors). At
http://apfelwiki.de/wiki/Main/Tastenkom ... chnerstart (in
German, sorry) I found the key combination


(held during restart) which boots from the external harddisk. I do not
know what happens if there are several externals harddisk but I have
only one, so it worked fine. The boot process got stuck for a few
seconds during "Scanning for Firewire Disks" but afterwards it proceeded
normally and brought up a functional Linux installation. I still do not
get network connectivity because DHCP fails but this is another story.

BTW: why, oh why, do users with German keyboards still have to patch the
keyboard layout files manually to get access to characters which require
AltGr (like |)? This problem has been known for years. What can be done
that this is fixed in future versions of YDL?

Anyway, I hope these explanations help other people who run into the
same problem as I did. I do not know why the firewire drive was not
detected automatically and why I had to jump through these hoops but I
am happy that it eventually worked. If someone from Terrasoft Solutions
wants to track down the problem I would be glad to help. I am a Unix
programmer by profession so I am not completely clueless about Linux.

Martin "Jerry" Jerabek
Til our paths cross again
User avatar
Posts: 959
Joined: 12 Jul 2004, 16:26
Location: Ft. Wayne, IN; USA

Return to F.A.Q. - F.requently A.sked Q.uestions

Who is online

Users browsing this forum: No registered users and 1 guest