Disabling Trackpad on G4 Powerbook

Architecture specific questions.

Disabling Trackpad on G4 Powerbook

Postby chris0531 » 18 Aug 2008, 22:35

It's really annoying that when I'm typing on my laptop the curser jumps across the screen because I brush against the trackpad with my palm.

I normally use a mouse (USB) with my laptop anyway, so I am wondering if it was possible to turn off the trackpad.

I'm using YDL 6.0 installed on a G4 Powerbook: http://www.everymac.com/systems/apple/powerbook_g4/stats/powerbook_g4_500.html

Be easy on me, I'm new to Linux and especially on a MAC.

ydl newbie
ydl newbie
Posts: 2
Joined: 01 Aug 2008, 04:08
Location: South Plainfield, NJ - USA

Re: Disabling Trackpad on G4 Powerbook

Postby Peter_Srp » 19 Aug 2008, 11:02

I had the same problem but did not find any solution. Usually (like MacOS 9) you can have a setting disabling the pad when typing but not here afaik. And I know we should not say that here, but YDL 6 gave me so much trouble (cups not working properly, log out not working properly, unchanged startup picture working not properly aso) that i gave openSUSE 11 PPC with Gnome a shot and found out it works flawless against YDL and the keyboard is layouted like an Apple keyboard should be, without funny tricks. Well yeah asked if its slow when REALLY working i would say the same as YDL 6. Maybe i give that another shot with 6.1 or such, as i can play with my PowerBook as much as i want. The files are all on my server box and so formating the HD is only a click away :)

Oh and btw, I am one step beyond lol http://www.everymac.com/systems/apple/p ... 4_667.html
ydl newbie
ydl newbie
Posts: 16
Joined: 02 Aug 2008, 10:38

Re: Disabling Trackpad on G4 Powerbook

Postby chris0531 » 19 Aug 2008, 18:32

I didn't have much problem installing YDL 6. As a matter of fact, the system is running fairly well, to my use, and I use it for 2 things: surfing the net and writing with OpenOffice. I haven't explored every aspect of the system, so I can't attest to flawlessness, but it does run decently.

Well, maybe I spoke too soon, and perhaps you have the same problem...

Does your system "hiccup" every so often? What I mean by "hiccup" is a momentary freeze. For instance, if i travel my mouse pointer from one end of the screen to the other, every so often, the pointer would freeze and skip/jump to the where it supposed to be. This gets annoying when navigating menus. Sometimes the hiccuping is coinciding with my mouse clicking, and I find myself waiting (the cpu is slow, after all) for no reason because the click did not register.

Has anyone ever experienced this?? Is it because the CPU is slow (500MHz)? Or is there something else at work here? It's not memory issues... I have 1gb of ram and the paging partition has not been used since I upgraded the ram. I previously had only 256mb of ram, so I upgraded to 1gb. But the problem is still there. Oh, and this problem exists when using Enlightment, Gnome, and KDE, so I don't thinks it's a windows manager issue (perhaps the X Windows System?). I'll admit, I haven't tried Xfce, yet. But I am temped, once I figure out how!

If this has happened to anyone, please let me know. And, if there is a solution, please don't hold back on me!!
ydl newbie
ydl newbie
Posts: 2
Joined: 01 Aug 2008, 04:08
Location: South Plainfield, NJ - USA

Re: Disabling Trackpad on G4 Powerbook

Postby trnunes » 22 Aug 2013, 15:06

Leon & other iBook G4 users of YDL 6.2 suffering from the frustrations of 'phantom mouse clicks',

I believe I've solved this problem. The problem appears to be caused by the fact that, though the Synaptics Touchpad driver *is* installed in a default YDL 6.2 installation, it is not *configured* as a Synaptics Touchpad. In such a configuration, the installed Synaptics driver simply operates in mouse emulation mode... Which, as you and I well know, can cause a normally sane person to self-medicate in mass quantities. ;-)

The solution? Through the help of a post on the Debian wiki (https://wiki.debian.org/MacBook#Synaptics_Touchpad), I was able to edit my /etc/X11/xorg.conf file to properly enable the features of the Synaptics Touchpad driver *and* (here's the most important part) DISABLE THE TOUCHPAD'S 'TAP AND CLICK' support. Here are the steps I took:

1.) Open a terminal window
2.) "su -" and enter root password
3.) "cp /etc/X11/xorg.conf /etc/X11/xorgconf.org" (creating a backup of your X11 config file, just in case you screw something up)
4.) "gedit /etc/X11/xorg.conf" (here's where you edit the file, referencing my edited xorg.conf file pasted below)
5.) Save your edited xorg.conf file in gedit, exit out of su mode, exit out of term, reboot (or reinit... I chose to reboot)

That's all there is to it. I've typed this entire post with ZERO 'phantom click issues' (e.g. no cursor jumping around unexpectedly, no unexpected selections/deletions of text, etc.) for the first time EVER (YAY!!!!). Here's my edited xorg.conf file, so you can replicate my own edits (NOTE: I simply REM'arked ("#") out the generic "mouse0" references/section and added the "Synaptics Touchpad" lines/section. I made no other edits to my file. Again, see below...):

# Tim N.'s edited /etc/X11/xorg.conf file to better support the Synaptics Touchpad on an Apple iBook G4
# File generated by Xautoconfig.
Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
# InputDevice "Mouse0" "CorePointer"
InputDevice "Synaptics Touchpad" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "OffTime" "10"

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

FontPath "/usr/share/X11/fonts/misc:unscaled"
FontPath "/usr/share/X11/fonts/Type1/"
FontPath "/usr/share/X11/fonts/Speedo/"
FontPath "/usr/share/X11/fonts/75dpi:unscaled"
FontPath "/usr/share/X11/fonts/100dpi:unscaled"
FontPath "/usr/share/X11/fonts/korean:unscaled"
FontPath "/usr/share/X11/fonts/cyrillic:unscaled"
FontPath "/usr/share/fonts/ISO8859-2/misc:unscaled"
FontPath "/usr/share/fonts/ISO8859-2/75dpi:unscaled"
FontPath "/usr/share/fonts/ISO8859-2/100dpi:unscaled"
FontPath "/usr/share/fonts/ISO8859-9/misc:unscaled"
FontPath "/usr/share/fonts/ISO8859-9/75dpi:unscaled"
FontPath "/usr/share/fonts/ISO8859-9/100dpi:unscaled"
FontPath "/usr/share/fonts/KOI8-R/misc:unscaled"
FontPath "/usr/share/fonts/KOI8-R/75dpi:unscaled"

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "freetype"
Load "type1"
#Load "dri"

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
# Change "XkbModel" to "macintosh_old" if you are using
# the deprecated adb keycodes.
Option "XkbModel" "macintosh"
Option "XkbLayout" "us"

# Section "InputDevice"
# Identifier "Mouse0"
# Driver "mouse"
# Option "ZAxisMapping" "4 5"
# Option "Protocol" "IMPS/2"
# Option "Device" "/dev/input/mice"
# EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "SHMConfig" "true"
Option "MaxTapTime" "0"
Option "HorizScrollDelta" "0"
Option "VertScrollDelta" "30"
Option "TapButton1" "0"
Option "TapButton2" "0"
Option "TapButton3" "0"

Section "Monitor"
Identifier "Monitor0"
ModelName "Monitor Model"
Option "DPMS"
HorizSync 30-70
VertRefresh 50-160


Section "Device"
Identifier "Card0"
#Option "ShadowFB" "true"
#Option "fbdev" "/dev/fb0"
Driver "fbdev"
#BusID "0:0:0"

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 15
SubSection "Display"
Depth 8
Modes "1024x768"
SubSection "Display"
Depth 16
Modes "1024x768"
SubSection "Display"
Depth 24
Modes "1024x768"
SubSection "Display"
Depth 15
Modes "1024x768"

Section "DRI"
Group 0
Mode 0666
#End of TRNunes' edited /etc/X11/xorg.conf file


~ TRNunes, 08/22/13
ydl newbie
ydl newbie
Posts: 10
Joined: 10 Jul 2013, 00:36

Re: Disabling Trackpad on G4 Powerbook

Postby trnunes » 16 Sep 2013, 21:02


One caveat to my prior G4 touch pad fix... I've since discovered that said fix ceases to work after a suspend/resume. If you never suspend/resume, it's a non-issue. I believe the problem lies in a script (or scripts) related to suspend/resume, but haven't had time to further debug the problem. I've simply been avoiding suspending/resuming.


~ T.R. Nunes, 09/16/13
ydl newbie
ydl newbie
Posts: 10
Joined: 10 Jul 2013, 00:36

Return to iBooks and Powerbooks

Who is online

Users browsing this forum: No registered users and 2 guests