eMac (USB 2.0) - Checking Before Installation

Architecture specific questions.

eMac (USB 2.0) - Checking Before Installation

Postby Broken » 15 Oct 2008, 01:14

Greetings! Fresh meat, here. I know precious little about Mac hardware, so forgive me if some of my question seems obvious.

I'm typing this post from my eMac (USB 2.0) -- G4 1.25Ghz, Radeon 9200, 40GB drive, DVD player/CD-RW, and that fine 17" built-in CRT. I don't use the Mac mouse or keyboard (MS Wheelmouse Optical and MicroInnovations KD565BL Multimedia Keyboard). For now it runs SUSE 11.0, but not without issues. As you might expect, I got past the partitioning business (pdisk is so much fun), and I have no intention of running OS X, though I have had Leopard on this thing. Further, I'm quite at home with CentOS running on other hardware, and have played with RH off and on since about 5.0.

While I see references in the forum archives to models similar to mine, I find the TerraSoft site a little ambiguous on whether my hardware is supported. It lists "eMac" with the most ancient G3s, yet says it should work quite fine with all other G4s (particularly iMacs). I'd be comfortable with running YDL 5.x, and would even consider 4.x., but latest is greatest in general, no? I have DSL and access to a DVD burner, so that's not an issue. My Mac is currently my only system. I'm a writer, for the most part, and Linux/BSD are my style for the tools, etc. (BSD does not support booting from the harddrive with OpenFirmware, yet).

Can anyone here help me assess the likelihood I can get one of the YDL releases installed and running without major suffering? I have the advantage of having configured a very solid xorg.conf for openSUSE. I'm not in a position to struggle too awfully long with this, but I'd like to use something which might offer a better fit for my habits.
Linux in the House Church
User avatar
Broken
ydl newbie
ydl newbie
 
Posts: 2
Joined: 15 Oct 2008, 00:45
Location: Choctaw, OK

Re: eMac (USB 2.0) - Checking Before Installation

Postby billb » 15 Oct 2008, 14:13

I do see this on their technical advisories page:

http://www.terrasoftsolutions.com/suppo ... ries.shtml
Radeon 9200 with Apple Cinema Display = no go
It appears that the combination of a Radeon 9200 graphics card (found in Mac minis and G4 towers) may not be able to talk to certain Apple Cinema displays, keeping graphical and potentially text modes from working. At this point in time, there is no work-around other than to use a different monitor.


Though it doesn't seem that would apply to you since you have a built-in CRT monitor.

Unfortunately we don't have too many Mac guys posting here, and I don't have one myself. I am interested in getting a PPC Mac for use with YDL at some point (when I find one at a good price), but I'm not clear on which model would be best supported by YDL 6 (and later, hopefully). I had a G3 iMac I used with YDL 5.0.2 for a while, but gave it away.

Another place you might post this question is on YDL's general mailing list at:

http://lists.terrasoftsolutions.com/mai ... og-general

Good luck with it! :)

Good luck!
PS3 60GB [CECHA01], FW 3.15, YDL 6.2, Samsung T260HD @ 1920x1200
Powermac G4 1.25 GHz x2, 2 GB RAM, YDL 6.2
User avatar
billb
Site Admin
Site Admin
 
Posts: 5522
Joined: 24 May 2007, 20:30
Location: Eastern NC, USA

Re: eMac (USB 2.0) - Checking Before Installation

Postby Broken » 15 Oct 2008, 15:01

As you suggest, I suspect that known problem doesn't apply to me. However, I have posted to the mailing list and will see if anyone knows enough to be helpful. Thanks.
Linux in the House Church
User avatar
Broken
ydl newbie
ydl newbie
 
Posts: 2
Joined: 15 Oct 2008, 00:45
Location: Choctaw, OK

Re: eMac (USB 2.0) - Checking Before Installation

Postby ppietro » 09 Nov 2008, 02:35

Broken wrote:I'm typing this post from my eMac (USB 2.0) -- G4 1.25Ghz, Radeon 9200, 40GB drive, DVD player/CD-RW, and that fine 17" built-in CRT.

While I see references in the forum archives to models similar to mine, I find the TerraSoft site a little ambiguous on whether my hardware is supported.


True - true.

This might help:
http://www.terrasoftsolutions.com/suppo ... hers.shtml

The following WERE officially supported through Yellow Dog Linux v5.x and may function with the current release, with some devices (ie: sound, video) not fully supported. In addition, those which do not offer a bootable DVD reader may require netbooting or the use of CD ROM images. The netboot image is available on the YDL DVD. CD ISOs (images) are not available from Terra Soft:

New World ROM G3s (anything before the G4 product line): Blue & White tower, iMac G3, iBook G3


The way you interpret this statement is that these machines are the cut-off for YDL 5.0x. They might work with 6.0, but they're not officially supported. Since your machine, being a G4, is newer that these, I would interpret this as that your machine should work and be supported with YDL 6.0.

Realize, though, that I am not a TerraSoft employee, and that I too own a PS3. :D

Cheers,
Paul
User avatar
ppietro
Site Admin
Site Admin
 
Posts: 4965
Joined: 13 Sep 2007, 22:18


Return to eMac and iMac

Who is online

Users browsing this forum: No registered users and 0 guests

cron