Late iBook G4 and Wifi (BCM4318) not working

Architecture specific questions.

Late iBook G4 and Wifi (BCM4318) not working

Postby Linschn » 15 Jul 2009, 22:14

Hi !

I tried to make the wifi work on my iBook G4 (bearing a broadcom 4318 chipset) as explained there : ... reme.shtml
ans there : ... fw-b43-new

I think (but am not sure) that the problem is not firmware related, because the interface is seen by ifconfig :
Code: Select all
wlan0     Link encap:Ethernet  HWaddr 00:11:24:C9:12:D5 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

And in dmesg, I get :

b43-phy0: Broadcom 4318 WLAN found
b43-phy0 debug: Found PHY: Analog 3, Type 2, Revision 7
b43-phy0 debug: Found Radio: Manuf 0x17F, Version 0x2050, Revision 8
b43-phy0 debug: DebugFS (CONFIG_DEBUG_FS) not enabled in kernel config
phy0: Selected rate control algorithm 'pid'
Broadcom 43xx driver loaded [ Features: PM, Firmware-ID: FW13 ]
firmware: requesting b43/ucode5.fw
firmware: requesting b43/pcm5.fw
firmware: requesting b43/b0g0initvals5.fw
firmware: requesting b43/b0g0bsinitvals5.fw
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0 debug: Chip initialized
b43-phy0 debug: 32-bit DMA initialized
b43-phy0 debug: Wireless interface started
b43-phy0 debug: Adding Interface type 2
ADDRCONF(NETDEV_UP): wlan0: link is not ready

At first, I thought that the "ADDRCONF(NETDEV_UP): wlan0: link is not ready" was a problem, but when googling for my problem, I stumbled upon people posting logs of working setups, and it contained this very line.

When I do a "iwlist wlan0 scan", I get no results. I'm sitting on the ground, less than 1 meter away from my access point.

I am completetly stuck.

Any Idea ?

(P.S. It worked on debian, and before that on Gentoo (and I followed the same procedure for the installation under Gentoo))
ydl newbie
ydl newbie
Posts: 4
Joined: 04 Jul 2009, 17:49

Re: Late iBook G4 and Wifi (BCM4318) not working

Postby ozorba » 30 Jul 2009, 08:49

I am having the same prblem with the Airport. My one is an iBook G4 and bought it in 2005.

ydl newbie
ydl newbie
Posts: 2
Joined: 30 Jul 2009, 08:45

Re: Late iBook G4 and Wifi (BCM4318) not working

Postby ozorba » 01 Aug 2009, 16:45

After few slepless nights I have decided to abandon the YDL. I have installed Debian Lenny and after few tewaks everything works.

ydl newbie
ydl newbie
Posts: 2
Joined: 30 Jul 2009, 08:45

Return to iBooks and Powerbooks

Who is online

Users browsing this forum: No registered users and 0 guests