Ultrastar

YDL running on the Sony Playstation 3

Moderator: billb

Postby Jaycounet » 11 Jan 2008, 19:06

the problems seems to be aout alsa

>>> Recording from alsa
-!- ALSA snd_pcm_open failed: Aucun fichier ou répertoire de ce type
>>> Recording from gst


and I got a problem with volume control

any idea ?

[jaycounet@localhost ~]$ gnome-volume-control
OIL: ERROR liboiltest.c 403: oil_test_check_impl(): function copy_u8_altivec in class copy_u8 failed check (412 > 0) || (outside=0)
Image
User avatar
Jaycounet
ydl beginner
ydl beginner
 
Posts: 42
Joined: 05 Dec 2007, 12:01
Location: France

Postby Jaycounet » 14 Jan 2008, 11:29

no idea about this sound problem ?
Image
User avatar
Jaycounet
ydl beginner
ydl beginner
 
Posts: 42
Joined: 05 Dec 2007, 12:01
Location: France

Postby billb » 22 Mar 2008, 09:58

I have ultrastar-ng working on YDL 6. At least the graphics and audio are OK, anyway ... I haven't connected a microphone yet.

Here's what it looks like:

Image Image Image Image

A zero score since there is no microphone connected ... of course if there was one connected and I was singing, the score might be similar ... :lol:
PS3 60GB [CECHA01], FW 3.15, YDL 6.2, Samsung T260HD @ 1920x1200
Powermac G4 1.25 GHz x2, 2 GB RAM, YDL 6.2
User avatar
billb
Site Admin
Site Admin
 
Posts: 5520
Joined: 24 May 2007, 20:30
Location: Eastern NC, USA

Postby Jaycounet » 29 Mar 2008, 12:02

I've istall YDL 6 and I start well when I COmpil Ultrastar

configure: error: C++ compiler cannot create executables


Any idea ?
Image
User avatar
Jaycounet
ydl beginner
ydl beginner
 
Posts: 42
Joined: 05 Dec 2007, 12:01
Location: France

Postby billb » 29 Mar 2008, 14:13

Jaycounet wrote:I've istall YDL 6 and I start well when I COmpil Ultrastar

configure: error: C++ compiler cannot create executables


Any idea ?


I'll go back and look at it again today to see if I did anything special. I don't recall ever seeing that message before.

Did you ever get a USB microphone working?
PS3 60GB [CECHA01], FW 3.15, YDL 6.2, Samsung T260HD @ 1920x1200
Powermac G4 1.25 GHz x2, 2 GB RAM, YDL 6.2
User avatar
billb
Site Admin
Site Admin
 
Posts: 5520
Joined: 24 May 2007, 20:30
Location: Eastern NC, USA

Postby Jaycounet » 29 Mar 2008, 14:27

no never on the 5.0 version that's why I would try the 6th :)

but for the moment I'm block :p

and I still have my problem with my volume controler that is not active because I don't have any gstreamer ....
Image
User avatar
Jaycounet
ydl beginner
ydl beginner
 
Posts: 42
Joined: 05 Dec 2007, 12:01
Location: France

Postby Jaycounet » 07 Apr 2008, 12:51

any news ?
Image
User avatar
Jaycounet
ydl beginner
ydl beginner
 
Posts: 42
Joined: 05 Dec 2007, 12:01
Location: France

Postby billb » 07 Apr 2008, 15:53

Jaycounet wrote:any news ?


I haven't done much with it lately. Still need to figure out how to get a microphone working properly ... audio on Linux is extremely frustrating, and the PS3 sound driver doesn't make it any easier ...
PS3 60GB [CECHA01], FW 3.15, YDL 6.2, Samsung T260HD @ 1920x1200
Powermac G4 1.25 GHz x2, 2 GB RAM, YDL 6.2
User avatar
billb
Site Admin
Site Admin
 
Posts: 5520
Joined: 24 May 2007, 20:30
Location: Eastern NC, USA

Postby Jaycounet » 07 Apr 2008, 15:55

yes but install first because for me I can't comile it for the moment on YDL 6 ! :p
Image
User avatar
Jaycounet
ydl beginner
ydl beginner
 
Posts: 42
Joined: 05 Dec 2007, 12:01
Location: France

Re: Ultrastar

Postby Chris1982 » 26 Aug 2008, 10:04

Hello!
Is someone still working on this topic?
We have managed to compile and start UltrastarNG on YDL@PS3 (YDL 5.0).
But we have problems with the microphones.
Has anybody made some experience with the original SingStar-USB Microphones? (How to tell UltrastarNG to use the USBMIC instead of the internal SoundDevice)
Has anybody tried to compile with gstreamer instead of XINE/alsa?

I am looking forward to some answers.

greetings,
Chris
Chris1982
ydl newbie
ydl newbie
 
Posts: 2
Joined: 26 Aug 2008, 09:51

Re: Ultrastar

Postby billb » 26 Aug 2008, 12:15

It has been a long time since I messed with it ... the last time I tried it I had some problems and got absolutely zero support from the developer(s). See this post on sourceforge:

http://sourceforge.net/forum/forum.php? ... _id=622996

Also, it looks like they plan to drop 2D support:

http://sourceforge.net/forum/message.php?msg_id=4914917

I never got any microphone working for any application on PS3 Linux so far ... when you boot with a microphone plugged in you may be able to go to System -> Administration -> Soundcard Detection and change the default for audio input, but I haven't had any luck with it.
PS3 60GB [CECHA01], FW 3.15, YDL 6.2, Samsung T260HD @ 1920x1200
Powermac G4 1.25 GHz x2, 2 GB RAM, YDL 6.2
User avatar
billb
Site Admin
Site Admin
 
Posts: 5520
Joined: 24 May 2007, 20:30
Location: Eastern NC, USA

Re: Ultrastar

Postby Chris1982 » 26 Aug 2008, 13:12

Well, it seems to be a hard job :)

I followed your links. You have obviously compiled the program with gstreamer :( We hoped gstreamer instead of xine would solve our problem. Unfortunately that doesnt seem to be the case.

Booting the system with the UsbMics plugged in doesnt give an entry in the sound configuration menu :(

This evening or tomorrow we will try to get a sound signal to aldacity. A friend of mine has a lot of experience in linux.

I will post our progress here!
Chris1982
ydl newbie
ydl newbie
 
Posts: 2
Joined: 26 Aug 2008, 09:51

Previous

Return to Playstation 3

Who is online

Users browsing this forum: No registered users and 0 guests